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SimplePCI Image Processing and Analysis (IPA) broadens SimplePCI,  to customize icon driven work-files 
(macros) for multiple applications.  Innovative interactions between image objects, graphs, and tables provide 
instant user feedback. The user can select and customize over 150 measurements to quantify count, size, 
shape, position, intensity and color of objects in an image.

Directly load images into SimplePCI IPA and select the functions to solve the application.  The procedure is 
methodical, where the operator selects each option interactively.  Save or view the steps in a work-file (macro), 
and load the work-file for automated data collection with immediate statistical analysis.

 
    Expand the functionality of SimplePCI and IPA by adding the following optional modules:
  AIC, automated control and image acquisition
  DIA, dynamically measure intensity over time
  IPA-MTA, track and analyze moving objects
  QFA-FRET, accurate FRET measurements and cross talk correction
  VIS-MD, provides rapid 3D visualization of multi-dimensional data sets
  DNN, Remove or Restore blur in images using fast algorithms
  DNN-2D, a Point Spread Function is derived and used in restoration

This Quick Start Guide contains examples of how to utilize IPA.  For further assistance, refer to the online 
help, manual, or visit support at http://www.cimaging.net, for access to the latest How to’s and frequently asked 
questions.  Additional support is available at e-mail: support@cimaging.net, or Tel: 412-741-7920.
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A workfile is the basic mechanism for automating image acquisition, processing and  
measurement operations. The workfile contents can be considered as a macro language, 
without the user having to deal with complicated textual interface.  The workfile is created and modified 
by the user selecting the imaging icons from the Task Toolbar (fig.1).  Each icon in the Task Toolbar 
will open a dialog for the manipulation of the current image on display using a variety of image capture, 
processing and measurement tools.  The options selected are saved as a Workfile.  
 
1.	 Click on the New icon to create a new Workfile Document.  Select Workfile Document 

and click OK.

2.	 Click the Capture icon to activate the Capture window (fig.2) and the Image Display 
(fig.3).

3.	 In the Capture window, select Disk from the top-right dropdown menu and set the number of 
color to Auto Depth.

4.	 Click on the Open icon (fig.2) in the Capture window, locate and 
select the image, click Open.  The image will appear in the Image 
Display (fig.3). 
If you would like to automate an image capturing event, select 
a camera device from the drop-down list, top-right. Make 
all selections and procedures as you normally do for image 
acquisition.  And follow the steps described below.

5.	 Click the Enhance icon in the Task toolbar if the image needs any 
type of image processing for easy identification.  If the image does 
not need any enhancement, go to the next step.

6.	 Click the Identify icon in the Task toolbar to open the Indentify Objects window. 
Set the threshold of your image by adjusting the Min. and Max. slider until the 
objects of interest are covered by a green binary overlay (threshold).  Click OK. 

7.	 Click the Modify icon in the Task toolbar if you need to modify 
your binary image with a binary filter, such as Erode, Dilate, 
Close, Open, etc.

8.	 Click the Qualify icon in the Task toolbar to reject unwanted 
objects from your binary overlay.

9.	 Click the Measure icon in the Task toolbar to open the Select 
Measurement window.  Check or customize the desired 
measurements. Click OK.

10.	 Save the Workfile (fig.4). File menu > Save As > assign a file name 
> Save (fig.5).

fig.5

fig.3

fig.2

fig.1Open image

Workfile

Task Toolbar/use these 
icons to create a Workfile

fig.4

Create a Workfile
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1.	 Open the Workfile if it is not open. File > Open > Workfile Document >OK > 
Select file > Open (fig.6). 

2.	 Open the *cxd file to be analyzed. File > Open > Data Document > OK > 
Select file > Open.  Note: To run the workfile on non-cxd image files, 
go to step 4. 

3.	 Click the Start Collecting icon (fig.7) in the Data Document toolbar > assign 
a file name > Save > Check all the data components (fig.8) to be included in 
the measurements > OK > Click Start in the Task toolbar. 

4.	 If you have non cxd-files, follow the following steps. *Note that if 
you have a sequence of images, you can import them as a cxd file 
allowing to run the workfile as described above.

5.	 Click on the Start Collecting icon (traffic light) (fig.9) in the Task Toolbar > Assign file 
name > Save > Scan > select Time Scan and Continous > Finish > Record, check all 
data components > Start.  

6.	 Open image file. Click  the Open icon in the Capture window (fig.10) and open an image 
file. Open > select image > Open, the image will appear in the Image Display.  Make 
sure to have Runtime Menu checked in the Capture window (fig.10).  Runtime menu 
pauses the workfile to open an image or change settings >Click OK.

7.	 After the workfile has finished running, the Capture window will appear again allowing you to open 
the next image.   

8.	 Click Stop Collect when finished (fig.10).  A new data file *cxd will have a data tree with several 
folders containing all the measurements and image details (fig.11).

Start Collecting icon

fig.6
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Run a Workfile for Image Analysis on Existing Images
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1.	 Click the Measure icon in the Task Toolbar (fig.12). 

2.	 Click Define in the Select Measurements window (fig.13). 

3.	 Click Add in the Custom Object Measurement Menu and assign a name to your custom 
measurement. E.g. Ratio (fig.14)

4.	 Select the desired Object Measurements or Field Measurements, and Operators. E.g. M8:Mean_
Red/M14: Mean_Green. 

5.	 Save the custom measurement. Click on the Save icon at the bottom-left of the Custom Object 
Measurement Menu, and click OK. 

6.	 Select the custom measurement from the Select Measurement window.   

7.	 To re-open the custom measurement, click Measure > Define > click the folder icon at the bottom-left of 
the Custom Object Measurement Menu > select file > Open.

1.	 Click the Camera icon.

2.	 Click  the Open icon in the Capture window and open an 
image file. Open > select image > Open, the image will 
appear in the Image Display.

3.	 Click the ROI button in the Capture window.   

4.	 Draw ROIs > OK >Close the Capture window.

5.	 Click the Identify icon and set the threshold of your 
image (fig.15).  A green overlay will appear in the area 
outside and inside the ROIs (fig.16). 

6.	 Click the Qualify icon in the Task toolbar

7.	 Click the ROI Edge Object icon (fig.17) 

8.	 Select Cut off objects outside the edge (fig.18).
ROI Edge Object

fig.12
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fig.17
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Create Custom Measurements

Analyze Objects Inside a ROI
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1.	 Create a new Workfile.  File > New > Workfile 
Document > OK

2.	 Click the camera icon to activate the Capture window 
and the Image Display (fig.19)

3.	 Select Disk from the top-right drop-down menu.  Click 
the Open icon in the Capture window.  Locate Blood 
Cells.tif in the example CD.  Examples/Images/
Blood Cells.tif > Open.  The image will appear in the 
Image Display (fig.19).  

4.	 Close the Capture window.  Click Identify in the Task 
toolbar.  Adjust the minimum and maximum  
sliders until the objects of interest on the image are 
covered with green overlay (fig.20). 

5.	 Click on the Qualify icon in the Task toolbar.  Reject unwanted 
objects by moving the top or bottom slider until unwanted 
objects appear red (fig.21)

6.	 Click Measure in the Task toolbar.  Check Area and Diameter 
(fig.22).  Click OK.

7.	 Close the Image Display and save the Workfile.  File > Save 
As > assign a file name > Save

8.	 Run the Workfile.  Click Start Collecting in the Task toolbar > Assign a file 
name > Save > Check Data Components to be recorded > OK 

9.	 Click Start.  The Capture window and the Image Display 
appear.  Open the Blood Cells.tif image if it’s not open.  
Click OK on the Capture window. The Workfile will complete 
one cycle of the process and return to the Capture window.  
Other images may be open for multiple field analysis.  In 
this example, there is only one image; therefore, click on the 
Stop Collect button to close the capture window and exit the 
operation loop.  Close the Image Display.

10.	 Review the *cxd file. The *cxd file will display object summary 
statistics, object summary graphs, field summary statistics, field summary 
graphs, field image montage, and field data.  In this case, the statistics are 
reported for Area and Diameter of the blood cells.  

11.	 The data can be easily displayed in spreadsheet 
form.  Figure 23 shows a Spreadsheet, which 
indicates the Area and Diameter for all of the black 
dots.

fig.19

fig.20

fig.21

fig.22

fig.23

open icon
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Blood Cell Example
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1.	 Create a new Workfile.  File > New > Workfile 
Document > OK

2.	 Click the camera icon to activate the Capture window and 
the Image Display (fig.24)

3.	  In the Capture window select Disk from the top-right 
dropdown menu (fig.24)  Click the Open icon.  Locate 
Coating Thickness.tif in the example CD.  Examples/
Examples/Images/Coating Thickness.tif > Open.  The 
image will appear in the image display.  

4.	 Close the Capture window.  Click the Enhance icon in 
the Task toolbar (fig.24).  Apply a Kirsh and a Smooth 
filter to the image.  The Kirsh filter uses a grey slider 
intensity gradient of a 3x3-pixel neighborhood in any 
direction.  It enhances the current image to highlight object boundaries (fig.25).  

5.	 Click the  Identify icon in the Task toolbar (fig.24).  Adjust the 
minimum to 27 and the maximum to 255 or move the sliders until 
the enhanced image of the coating is covered with a green overlay 
(fig.26).  

6.	 Click the Modify icon in the Task toolbar.  The Modify window 
appears (fig.27).  Click Draw Grid > Select Horizontal Grid 
and enter 255 for the Y spacing to create two horizontal lines > 
Fill Holes to join the green overlay > Open to remove unwanted 
artifacts > Click Save to save the current overlay in memory for 
use later > Click Clear to remove the current overlay > Draw Grid 
> Select Horizontal Grid and enter 3 for the Y spacing > click Math and select 
AND  to accept the lines where they match the previously saved overlay.  The 
complete process may be observed by clicking through the Steps # 0 to 7 
(fig.27).

fig.24

fig.25

fig.26

fig.27

open icon

Activate Capture Window

Task Toolbar

Coating Example
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7.	 Click on the Qualify icon in the Task toolbar. Reject unwanted 
objects by moving the top slider to 150, depending on the 
calibration factor loaded, or until unwanted objects appear red 
(fig.28).    

8.	 Click the Measure icon in the Task toolbar (fig.29).  Check 
Width to measure the width of the metal coating.

9.	 Close the Image display and save the Workfile.  File > Save 
As > assign a file name > Save

10.	 Run the workfile.  Click Start Collecting in the Task toolbar > Assign 
a file name > Save > Check Data Components to be recorded > OK 

11.	 Click the Start icon (fig.30) in the Task toolbar.  The Capture window 
and the Image Display appear.  Open the Coating Thickness.tiff 
image if it’s not open.  Click OK on the Capture window. The Workfile will 
complete one cycle of the process and return to the Capture window.  Other 
images may be open for multiple field analysis.  In this example, there is only 
one image; therefore, click on the Stop Collect button to close the Capture 
window and exit the operation loop.  Close the Image Display.

12.	 The data document (fig.31) will be displayed, giving access to object 
summary statistics, object summary graphs, field summary statistics, field 
summary graphs, field image montage and field data.  In this case, the data 
are reported for the Width of the coating.

fig.28

fig.29

fig.30

fig.31
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1.	 Create a new Workfile.  File > New > Workfile 
Document > OK.

2.	 Click the camera icon to activate the Capture window 
and the Image Display (fig.32).

3.	 Select Disk from the top-right dropdown menu (fig.32)  
Click the Open icon in the Capture window.  Locate 
muscle.tiff in the example CD.  Examples/Examples/
Images/muscle.tiff > Open.  The image will appear in 
the Image Display.  

4.	 Close the Capture window.  Click the Enhance icon in 
the Task toolbar (fig.32).  Apply a Kirsh and two passes 
of the Smooth filter to the image (fig.33).  The Kirsh 
filter will hightlight fiber boundaries by using a gray slider 
intensity gradient within a 3x3-pixel neighborhood  
of any direction. 

5.	 Click the  Identify icon in the Task toolbar (fig.32).  Adjust 
the minimum to 0 and the maximum to 68 or move the  
sliders until the muscle fiber is covered with a green binary 
overlay (fig.34).  

6.	 Click the Qualify icon in the Task toolbar.  Reject unwanted 
objects by moving the top slider to 1545 or until unwanted 
objects appear red (fig.35).

7.	 Click the Modify icon in the Task toolbar.  The Modify window appears 
(fig.36). Click Edit > press on the Open polygon shape and the Erase tool > 
Erase any connection between the fibers by drawing a line across the  
connection > Click Apply to preview and OK when finish. In the 
Binary Modification window, click Open to remove small links 
between the fibers > Fill Holes to ensure each fiber is solid > 
Open, apply two passes.

fig.32

fig.33

fig.34

fig.35

fig.36

open icon

Task Toolbar

openPolygon Shape

Erase Tool

Muscle Fiber Example
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8.	 Click on the Qualify icon.  Reject unwanted objects by moving the top slid-
er to 896 or until unwanted objects appear red (fig.37).  Remove objects 
touching the edges.  Click on the ROI Edge Object icon and select Delete 
All Edge Objects otherwise select No Edge Applied.  

9.	 Click the Measure icon in the Task toolbar (fig.38).  Check Width to mea-
sure the width of the metal coating.

10.	 Close the Image Display and save the Workfile.  File > Save As > assign 
a file name > Save

11.	 Run the Workfile.  Click Start Collecting in the Task toolbar > Assign a file name > 
Save > Check Data Components to be recorded > OK 

12.	 Click the Start icon (fig.39) in the Task toolbar.  The Capture window and the Image 
Display appear.  Open the muscle.tif image if it’s not open.  Click OK on the 
Capture window. The Workfile will complete one cycle of the process and return 
to the Capture window.  Other images may be open for multiple field analysis.  In 
this example, there is only one image; therefore, click on the Stop Collect button to 
close the Capture window and exit the operation loop.  Close the Image Display.

13.	 The data document (fig.40) will be displayed, giving access to object summary sta-
tistics, object summary graphs, field summary statistics, field summary graphs, field 
image montage and field data.  In this case, the data are reported for the Area, Max 
Length, and Max Breadth of the muscle fibers.

fig.37

fig.38

fig.39

fig.40
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Obective: 
To determine the amount of infarct area of the rat's brain. 

1.	 Create a new Workfile.  File > New > Workfile 
Document > OK.

2.	 Click the camera icon to activate the Capture 
window and the Image Display (fig.41).

3.	 Select Disk from the top-right drop-down menu 
(fig.41).  Click the Open icon in the Capture 
window.  Locate Brain Ischemia.tif in the 
example CD.  Examples/Examples/Images/
Brain Ischemia.tif > Open.  The image will 
appear in the image display.  

4.	 Close the Capture window.  Click Identify in 
the Task toolbar and set the threshold to identify 
the full brain.  Set the minimum slider for Red 
to 62, Green to 27 and Blue to 16, and set the 
maximum slider for the Red, Green and Blue 
channel to 255, or adjust the sliders until the full 
brain section is covered with a green overlay as shown in figure 42. 

5.	 Click on the Modify icon. Apply Fill Holes to fill any hole in the 
green overlay. Apply Open to remove any small artifacts. > OK 
(fig.43).

6.	 Click Measure > Define (fig.44), the Custom Object Measurement 
Menu appears (fig.45).  Click on the Custom Field Measurement 
Tab > Add > Type Full_Brain_Area > OK > Class #, enter 1. When multiple sliders 
of measurements are made, they are referenced as Class numbers. In this example, 
the first measured Area is Class 1. > Press F2: OBJ_Area 
in the measurements field. The custom measurement should 
look like figure 45. > Press OK.

7.	 Check Area in the Object tab and the custom measurement, 
Full_Brain_Area in the Field tab of the Select 
Measurement window and press OK (fig.44).

fig.43

fig.42

fig.44

fig.41

fig.45

Brain Ischemia Example

open icon

Task Toolbar
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8.	 Click Modify in the Task toolbar.  Apply Boundary to 
outline the infarct area  (fig.46) > Edit, draw a midline,  
press the Open Polygon Shape and Draw icon. Click 
and drag to draw a mid-line. > Click Apply > Press the 
Erase icon and the Open Polygon Shape to erase the 
top and bottom where the midline intercepts as shown 
in figure 47 > Click Apply and ensure that the line is 
separated from the other half > OK > Apply Fill Holes > Open 2 
passes (fig.46).

9.	 Click the Measure icon in the Task toolbar.  Click Define (fig.48) and 
create the following custom measurement as shown in figure 9: Half_
Brain_Area: Cl2(F2). Click OK.  See step 7 of this example or page 
3 of the SimplePCI Quick Guide on how to add custom measurement.  
Check the custom measurement in the Select Measurement window > 
Click OK (fig.48).

10.	 Click Identify.  Set the Minimum slider for Red to 216, Green to 122 and blue to 85 
and leave the maximum slider to 255, or adjust the slider until the infarct section of the 
brain is covered by a green binary overlay (fig.50).

11.	 Click the Measure icon in the Task toolbar.  Click Define (fig.51) and create the 
following custom measurements as shown in figure 49: Infarct_Area: F2 and Infarct_
Half_Ratio: UF3/UF2 (UF3= Infarct Area, UF2= Half_Brian Area). Click OK.   Check 
the custom measurement in the Select Measurement window > Click OK (fig.52).

12.	 Close the Image Display and save the Workfile.  File > Save As > assign a 
file name > Save.

13.	 Run the Workfile.  Click Start Collecting in the Task toolbar > Assign a 
file name > Save > Check Data Components to be recorded > OK. 

14.	 Click the Start icon in the Task toolbar.  The Capture window and the 
Image Display appear.  Open the Coating Thickness.tif image if it’s not 
open.  Click OK on the Capture window. The Workfile will complete one 
cycle of the process and return to the Capture window.  Other images may 
be open for multiple field analysis.  In this example, there is only one image; 
therefore, click on the Stop Collect button to close the 
Capture window and exit the operation loop.  Close the 
Image Display.

15.	 The data document will be displayed, giving access 
to object summary statistics, object summary graphs, 
field summary statistics, field summary graphs, field 
image montage and field data.  In this case the data are 
reported for the Width of the coating.
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